Roland EGX-30A Spindle Rotor Problem, Engraver LED Blinking

Post questions, share ideas and techniques relating to engraving and impact imaging
Post Reply
stolid
Member
Posts: 5
Joined: Sun Oct 28, 2012 1:43 pm

Roland EGX-30A Spindle Rotor Problem, Engraver LED Blinking

Post by stolid » Fri Apr 19, 2013 5:06 pm

After I execute the command to engrave, the spindle moves to the area to be engraved and the rotor starts spinning but after a second or two the spindle stops and the Engraver LED starts blinking. Then the operation just stops, I cant move using the arrow keys or pause the operation, only option is to hold the power to turn it off.

If I remove the cutting tool the rotor moves perfectly and finishes the whole operation but as soon as I install the cutting tool into the spindle after a initial rotation for about 2 secs it stops(this is even when the cutting tool is not touching the material), and the engraver led starts blinking.

The engraver was working perfectly before and I had no problems, but after this problem it doesn't even finish a letter before stopping. Can anyone help me out please ?

stolid
Member
Posts: 5
Joined: Sun Oct 28, 2012 1:43 pm

Re: Roland EGX-30A Spindle Rotor Problem, Engraver LED Blink

Post by stolid » Sun Apr 21, 2013 1:04 pm

SOLVED! Moderator please close this thread.

I figured out what the problem was after opening the spindle part using this guide as a reference

http://support.rolanddga.com/docs/Docum ... PEN_R2.pdf

I noticed that the reason the needle wasnt spinning properly was due to reason of waste getting clogged up near the nozzle after cleaning it out with WD-40 the spindle didnt have any problems moving.

User avatar
Andrew Dudley
Gold Member
Posts: 438
Joined: Tue Jul 26, 2011 10:04 am
Location: Clevedon - England
Contact:

Re: Roland EGX-30A Spindle Rotor Problem, Engraver LED Blink

Post by Andrew Dudley » Fri Apr 26, 2013 9:25 am

Hi,

Glad you found the solution online.
If you have serious problems like this you are best to call our tech team and log a ticket, that way we will make sure we get back to you.
Our tech guys don't check this part of the forum all the time so may miss your post for a few days.

Happy Engraving!
Andrew Dudley
Business Manager - 3D & Dental
Roland DG (UK) Ltd
Web: www.rolanddg.co.uk

bluebg1983
Member
Posts: 3
Joined: Wed Apr 06, 2016 12:35 pm

Re: Roland EGX-30A Spindle Rotor Problem, Engraver LED Blink

Post by bluebg1983 » Wed Apr 06, 2016 12:41 pm

I am facing a problem with my EGX30A Engraving machine, whenever we send the command to machine it moves towards the engraving position at the time of motor start it hangup and the LED starts blinking we try it without the spindle motor belt or you can say we make the motor free from the cutting tool but the result are similar. while we we execute command in SCORE mode it woks properly machine doesn't hang or stops and it finish the job properly,
we have 2 EGX30A machine both have same problem we are stuck. please help us what to do with this.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest