MDX 540/Mayka 7 toolpath export problem

Post questions, share ideas and techniques relating to 3D prototyping and milling
Post Reply
gerald nolan
Member
Posts: 9
Joined: Thu Jan 29, 2015 2:50 pm
Location: National College of Art & Design, Dublin

MDX 540/Mayka 7 toolpath export problem

Post by gerald nolan » Fri Feb 06, 2015 7:12 pm

Hello all,
This has been mentioned in another post (MDX spindle sensor problem) but I just thought I'd post this account of the issue. It might be of help to someone.
We are operating an MDX540 milling machine with automatic tool changer (ATC). Using Mayka 7 as CAM program. We recently upgraded the PC on the machine so our operating system is now windows 8 ( previously XP ). The problem that arose was, when exporting a cutting file from Mayka , an error message appeared on screen " this tool number is not authorised". This was followed by " the postprocessor has detected an error when saving the cutting file". It was possible to save a cutting file if tool no. 1 was specified, but tools no. 2,3 and 4 would bring up this error message.
The machine firmware was updated, drivers installed as normal.( Roland webpage)
Mayka 7 was removed and re- installed several times.
Choosing different types of postprocessor file from the export options did not help.
I contacted Roland about the problem, they replied that Mayka 7 is not their product and they have no expertise with it.
I then contacted Picasoft, who make Mayka. Described the problem.
They replied quickly and asked me to send them the postprocessor files for examination.
I have to state at this stage that I am not a software expert, so it took me a certain interval to locate these and send them off.
There were 2 with the letters ATC in the name.
( Program files/Picasoft/Mayka 7/Post/RDG MDX540 RML ATC XYZ (mm).post)
They replied with replacement files to install . I removed the old ATC files from the Post folder and dropped in the ones Picasoft sent.
That seems to have solved the problem. Toolpaths now export with all tool numbers.
It seems , I suppose, that the postprocessor files may have been corrupted on installation to the new PC??
Anyway, I hope this information is of use.
Thanks to mrtn in Estonia and Patrick Thorn for their advice and input.
'evening all,
Gerald Nolan

User avatar
Andrew Dudley
Gold Member
Posts: 438
Joined: Tue Jul 26, 2011 10:04 am
Location: Clevedon - England
Contact:

Re: MDX 540/Mayka 7 toolpath export problem

Post by Andrew Dudley » Thu Feb 26, 2015 12:59 pm

Hi Gerald,

Thank you for the update, it is nice to know you are working now.

Sometimes old versions of software need to be updated to work on new versions of Windows. As they don't always make windows 100% backwards compatable.

The Post Processor is the file that converts the cutting data you see in the CAM software to the code the machine uses.
Possibly there was something in the Post Processor you had for Win XP that was not supported, or changed slightly in Win 8.
As your Mayka 7 was probably compiled before Win 8 came out, it juest needed an small update to work.
Andrew Dudley
Business Manager - 3D & Dental
Roland DG (UK) Ltd
Web: www.rolanddg.co.uk

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests