Possible debris on print head? (Roland BN-20)

Post questions, share ideas and techniques related to sign-making and graphics production
Post Reply
Paspey
Member
Posts: 3
Joined: Wed Dec 07, 2016 12:57 pm

Possible debris on print head? (Roland BN-20)

Post by Paspey » Wed Dec 07, 2016 1:31 pm

Hello Roland Forum regulars! My name is Peter, I hope I'm positing this in the right board. I was wondering if you guys could help with an issue with our BN-20.

We're running a Roland BN-20 and have recently been having some issues with what looks like magenta ink being dragged across our designs on the print head. I've only recently started working with the BN-20, so followed an instructional video online alongside the instructions on the BN-20 Utility to carry out a manual clean. I've also ran both normal and powerful cleaning cycles on the BN-20 utility program. After cleaning, I ran a cut only print, which apart from some smeared ink on the right hand side of the medium looked fine. After the cut only I tried a small print which instantly had magenta lines starting from the right hand side.

I've read online that this can be caused by a piece of hair or debris on a part of the print head that is not visible when the print head is in its cleaning position?

I've attached some pictures (hosted elsewhere to preserve detail) that I took showing the excess magenta ink on both the medium guides and cap along with some prints from before and after cleaning:

http://imgur.com/gallery/ZjSSw

How would we go about getting access to check if there is debris hidden out of view?

Thanks for your help

Peter

User avatar
mrtn
Gold Member
Posts: 2297
Joined: Tue Feb 14, 2012 4:37 pm
Location: Tallinn, Estonia

Re: Possible debris on print head? (Roland BN-20)

Post by mrtn » Wed Dec 07, 2016 1:38 pm

Your felt is LOOOOOOOONG overdue. Probably captop and wiper as well. Looks like manual cleaning has not been performed in wiper/captop area.

When did you last have the printer serviced?
Roland Dealer since 1993
facebook
instagram

Paspey
Member
Posts: 3
Joined: Wed Dec 07, 2016 12:57 pm

Re: Possible debris on print head? (Roland BN-20)

Post by Paspey » Wed Dec 07, 2016 2:20 pm

Hi Mrtn (Martin?), I've been told that the printer hasn't been serviced in at least 2-3 years. I had cleaned the captop area thoroughly but there was so much ink it was almost impossible to clean it 100%. I will definitely look into getting the felt replaced then. I'm fairly sure that we recently replaced the wiper but I don't think we did the same for the felt.

Thanks for your speedy reply!

User avatar
mrtn
Gold Member
Posts: 2297
Joined: Tue Feb 14, 2012 4:37 pm
Location: Tallinn, Estonia

Re: Possible debris on print head? (Roland BN-20)

Post by mrtn » Wed Dec 07, 2016 2:37 pm

Makes sense. Make sure to have the captop replaced. It may clogged and not drain the excess ink leaving it smear everything.

Original parts only!
Roland Dealer since 1993
facebook
instagram

Paspey
Member
Posts: 3
Joined: Wed Dec 07, 2016 12:57 pm

Re: Possible debris on print head? (Roland BN-20)

Post by Paspey » Wed Dec 07, 2016 3:03 pm

We will get it replaced asap!

I've just put a small run of four prints through the printer and other than a pinch roll error when I first loaded the roll it seems to have come through without a hitch?

Perhaps the ink has dried that was being dragged across the medium?

Will update once we have replaced the parts you recommended!

Thanks for your help.

User avatar
Kai Perry
Moderator
Posts: 2178
Joined: Wed Aug 03, 2011 3:59 pm
Location: Clevedon
Contact:

Re: Possible debris on print head? (Roland BN-20)

Post by Kai Perry » Wed Dec 07, 2016 4:22 pm

Check the right hand side of the head carriage for a build up of dirt.
Kai Perry
RolandCare Advisor
Roland DG (UK) Ltd
http://www.rolanddg.co.uk

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest