GS-24 blade skipping issues?

Need advice on using your Roland Hardware.
Please note we do not give engineering advice in this group
Post Reply
billmags
Member
Posts: 5
Joined: Sat May 28, 2016 4:31 am

GS-24 blade skipping issues?

Post by billmags » Tue Jun 20, 2017 9:07 pm

Hi there,
Have been using my Roland GS-24 for about a year now, and it's started skipping. Tried a new blade and also replaced the cutting strip. Still skipping. It ONLY skips going in a straight line (front to back) - NOT sideways. Any ideas what could be causing this? I've tried re-setting the blade depth, played around with cut pressure/depths, etc. Nothing is working :(

Any help/ideas would be greatly appreciated! Thanks!

User avatar
woolly
Gold Member
Posts: 392
Joined: Tue Sep 20, 2011 10:13 pm
Location: Cornwall
Contact:

Re: GS-24 blade skipping issues?

Post by woolly » Wed Jun 21, 2017 12:50 am

If you mean skipping like a perforated cut but only in one direction normally being the blade holder is not allowing the blade to swivel properly.
The bearing that the blade act on only needs the slightest bit of grit to give trouble.
You could buy new or strip the old one wash out the bearings with wd40 rebuild with the smallest drop of machine oil ..
Enjoy

billmags
Member
Posts: 5
Joined: Sat May 28, 2016 4:31 am

Re: GS-24 blade skipping issues?

Post by billmags » Wed Jun 21, 2017 1:12 am

Thank you. I will try that!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest