Performing Head wash on BN20 and no cleaning solvent is getting consumed

General chat that doesn't fit into other categories
Post Reply
User avatar
FLG
Member
Posts: 21
Joined: Thu Jun 11, 2015 6:45 am
Location: United Kingdom
Contact:

Performing Head wash on BN20 and no cleaning solvent is getting consumed

Post by FLG » Mon Dec 04, 2017 9:45 pm

Well as the title says. Trying to clear the head on my BN20. I have performed 2 head washes now and not one gram of the cleaning solvent has been consumed.

I have tried head soaking and all manner of tricks but nothing seems to be getting it to work for me!

Ideas??

Nigel

User avatar
mrtn
Gold Member
Posts: 2628
Joined: Tue Feb 14, 2012 4:37 pm
Location: Tallinn, Estonia

Re: Performing Head wash on BN20 and no cleaning solvent is getting consumed

Post by mrtn » Tue Dec 05, 2017 12:26 am

1) captop is worn/leaking (needs to be replaced every 6 months)
2) pump is worn (needs to be replaced every 3 years, theoretically.
Roland Dealer since 1993
facebook
instagram

User avatar
FLG
Member
Posts: 21
Joined: Thu Jun 11, 2015 6:45 am
Location: United Kingdom
Contact:

Re: Performing Head wash on BN20 and no cleaning solvent is getting consumed

Post by FLG » Tue Dec 05, 2017 7:47 am

So the captop is replaced regularly but the pump not. I'll take a look . . . .

User avatar
mrtn
Gold Member
Posts: 2628
Joined: Tue Feb 14, 2012 4:37 pm
Location: Tallinn, Estonia

Re: Performing Head wash on BN20 and no cleaning solvent is getting consumed

Post by mrtn » Tue Dec 05, 2017 7:51 am

Don’t go buying the pump right away. It may be a defective captop still.

What’s the history of the machine? Did it work before or why are you performing head wash? That’s not something anyone would need to do, ever, in normal use.
Roland Dealer since 1993
facebook
instagram

User avatar
FLG
Member
Posts: 21
Joined: Thu Jun 11, 2015 6:45 am
Location: United Kingdom
Contact:

Re: Performing Head wash on BN20 and no cleaning solvent is getting consumed

Post by FLG » Tue Dec 05, 2017 8:15 am

It's not used much so I regularly have issues getting it working. I would say it's getting a little harder these past few times. It's about 5 years old but it really doesn't do much work. Last time I cleaned it through it worked just fine for the few days I was using it. That was 5 weeks ago now. It is powerd during daytime to do it's maintenance activities.

I will replace the cap top first to see if that helps with the wash.

User avatar
FLG
Member
Posts: 21
Joined: Thu Jun 11, 2015 6:45 am
Location: United Kingdom
Contact:

Re: Performing Head wash on BN20 and no cleaning solvent is getting consumed

Post by FLG » Fri Dec 08, 2017 3:15 pm

Well after some investigation I took a needle and punctured the membrane where the solvent feeds the printer on the cartridge. It looks like the pins in the printer didn't quiet puncture to the full depth of the membrane to get to the solvent. Head washes are now using solvent again! YaY!

User avatar
mrtn
Gold Member
Posts: 2628
Joined: Tue Feb 14, 2012 4:37 pm
Location: Tallinn, Estonia

Re: Performing Head wash on BN20 and no cleaning solvent is getting consumed

Post by mrtn » Fri Dec 08, 2017 5:01 pm

That's typical. The third party ink manufacturers use off standard cartridge sizes to circumvent license fees to the copyright holders. So the rubber valve seal is too thick and/or the cartridge does not seat correctly. There's a manufacturer who uses cartridges a couple of millimeters smaller and incorrect keys which allows the user to insert the cartridge at an angle and break the ink needle.
Roland Dealer since 1993
facebook
instagram

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 1 guest