EGX 300 spindle

Post questions, share ideas and techniques relating to engraving and impact imaging
Post Reply
Bowmere
Member
Posts: 2
Joined: Fri Nov 29, 2019 12:29 pm

EGX 300 spindle

Post by Bowmere » Fri Nov 29, 2019 2:04 pm

Hi there,

I'm using an EGX 300 in a high school to cut acrylic and mdf.
The machine has been well used, but now the spindle is starting to not run at continuous speed. It even stops completely on cuts of only .5mm
Does anyone know what might be at fault? Could there be a belt that could be slipping.
Also does anyone know where the machine could get a good service?

Any suggestions would be appreciated

Many thanks

Bowmere

User avatar
Kai Perry
Moderator
Posts: 3154
Joined: Wed Aug 03, 2011 3:59 pm
Location: Clevedon
Contact:

Re: EGX 300 spindle

Post by Kai Perry » Tue Dec 10, 2019 10:26 am

It could be the spindle belt, motor or spindle, if you remove the belt does the motor continously run?
Kai Perry
Application Engineer
Roland DG (UK) Ltd
http://www.rolanddg.co.uk

Bowmere
Member
Posts: 2
Joined: Fri Nov 29, 2019 12:29 pm

Re: EGX 300 spindle

Post by Bowmere » Thu Dec 19, 2019 3:50 pm

Thanks for your suggestion Kai,

I've taken the cover off the spindle. It's hard to see if the belt is slipping. It's not particularly tight and it does have some small nicks in it.
When running it kind of pulses, looking like the belt is getting looser then tighter and I can hear a pulsed drone as it moves. Not sure if it's the motor pulsing fast then slower or the belt slipping causing the pulse.

Please can you tell me where I can get a replacement belt - so that I can eliminate it and if that doesn't work, where to get a new motor.

Thank you so much for your help.

Steve

Post Reply

Who is online

Users browsing this forum: Kai Perry and 1 guest