Main Board on MDX-40A has blown

Post questions, share ideas and techniques relating to 3D prototyping and milling
Post Reply
Gerard.oconnor
Member
Posts: 1
Joined: Thu Jun 07, 2018 12:15 am

Main Board on MDX-40A has blown

Post by Gerard.oconnor » Thu Jun 07, 2018 1:18 pm

Hi, The main board on our MDX-40A blue and we replaced this board, 3 weeks later the new board went again, it is the same component that has gone on both boards, this component seems to relate back to the spindle head, is there something over loading this board? I don't want to replace this board again as they are expensive, any help on this matter would be appreciated.
We also have another machine an MDX-40 and a similar problem happened, we also replaced this main board but we can't get the front panel to light up, if we unplug one of the leads which connects the main board to a smaller board the front panel lights up, something seems to be shorting it, we would have checked all the leads for a break but have found nothing, again any ideas?

Regards Gerard

User avatar
Kai Perry
Moderator
Posts: 2479
Joined: Wed Aug 03, 2011 3:59 pm
Location: Clevedon
Contact:

Re: Main Board on MDX-40A has blown

Post by Kai Perry » Thu Jun 07, 2018 1:46 pm

It could be down to the spindle board but in all likeyhood you would need to replace both at the same time.

With the other unit I would look to replace the cable and the panel board.
Kai Perry
Application Engineer
Roland DG (UK) Ltd
http://www.rolanddg.co.uk

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest